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Index Phase 2
Data Base entries:

Directory: \\edaslaptop\C:\htdocs-copyof\LTERCatalog\CataforXML\TOEML

Files: TOEML-EML.DB

� 
TOEML-EML.DB:  Enter the values in this table corresponding to the new data set. See Table X2 below for field values specifications. 

< 
The “packageid” and “SHORTNAME” values depend on the unique record number assigned. The assignment of this number correspond to the number the data set makes in being added to the LUQ Information Management System (LUQIMS).

< 
In September 30 2005, there have been 135 data sets submitted and catalogued into the LUQIMS; some have been eliminated from the catalog because they did not meet the requirements of documentation, because the data was never completed and filed or because they were obtained from a government agency whose data is now accessible on the Web. 

< 
If a data set were submitted in October 1, 2005 the unique number would have been 136, its packageid knb-lter-luq.136.1, and its SHORTNAME LUQMetadata136.

Table X2. Fields entry specifications in the Paradox table TOEML-EML.DB

Name of Field
Description of Value to be entered
Format (if applicable)

packageid
An EML field that is unique for each EML package (corresponding to each data set). Contains the version number, that should be incremented when a change is made in the metadata.
knb-lter-luq.<unique record corresponding to the number in shortname>.<version number; 1=firstime that will be submitted>

E.g., knb-lter-luq.108.1

SHORTNAME
An EML field uniquely assigned to that data base (used as an identifier in the LUQ LTER Information System)
LUQMetadata<unique record number in this table>

E.g., LUQMetadata118

distribution
An EML field indicating the availability of the data on the Web
online (requires an URL in the next field)

offline

url
An EML field indicating “ ADVANCE \d 5A URL (Uniform Resource Locator) from which this resource can be downloaded or additional information can be obtained.”
E.g., http://luq.lternet.edu/data/lterdb118/metadata/lterdb118.htm#DATA







(Go to INDEX)

Project Information:

Directory: \\edaslaptop\C:\htdocs-copyof\LTERCatalog\CataforXML\TOEML

Files: LUQ-descriptions.DB (gets exported to Access Table LUQ-descriptions in the Access database: C:\htdocs-copyof\LTERCatalog\CataforXML\TOEML\TOEML-luq-Methods-Abs-ProjectDesc.mdb); TOEML-projects.DB

< 
LUQ-descriptions.DB: contains the abstracts and titles of the data sets and projects they belong to. Enter the data in this Paradox table as described in Table X5 below. Most of the fields are memo type, so when entering the information press the key “F2" first.

Table X5. Structure of Paradox table LUQ-descriptions.DB (abstract and titles of the data set).

Name of Field
Description of Value to be entered
Format (if applicable)

ID
Record number required by Access





abstract_para
Data Set abstract obtained from the Metadata Word form section: “DATA SET ABSTRACT: ”


shortname
A unique number that is assigned the data set in the Metadata database (in all tables the name referes to the same data set). Assigned in table TOEML-EML.DB

LUQMetadata<unique record number in this table>

E.g., LUQMetadata118

project_description
Description of the science project that originates the current data set and the scientific goals it wants to achieve. Obtained from the Metadata Word form section: “PROJECT DESCRIPTION :”



project_title
Title of scientific project that is obtained form the Metadata Word form section: “PROJECT TITLE:”


dataset_title
Title of data set that is obtained form the Metadata Word form section: “DATA SET IDENTIFIER:”. This title should uniquely identifies and describes concisely the data set.


methods_description


Description of the methods used to collect and analyze the data set that is obtained form the Metadata Word form section: “DATA SET METHODS:”


< 
TOEML-projects.DB associates the personnel involved in the project with the project and the data set; it contains the minimal information required by EML to document projects, except for the Project description which is contained in th Paradox table LUQ-descriptions.DB. Obtain the information to populate this table from the Metadata Word form completed by the investigator/research assistant. Table X6 bellow presents a description of the structure of the Paradox table TOEML-projects.DB and were to obatain the information from.




Table X6. Table TOEML-projects.DB structure (project’s personnel and database id).

Projectltitle
Title of scientific project that is obtained form the Metadata Word form section: “PROJECT TITLE:”


shortname
A unique number that is assigned the data set in the Metadata database (in all tables the name referes to the same data set). Assigned in table TOEML-EML.DB

LUQMetadata<unique record number in this table>

E.g., LUQMetadata118

PersonnelgivenName
The first name (including middle initials of persons involved in the project) whose role is being documented. EML requires at least that the principal investigator’s information is entered when documenting a project. The principal investigator entered in the “Principal Investigator” table of the “INVESTIGATORS:” section of the Metadata Word form.


Personnelsurname
The last name whose role is being documented. EML requires at least that the principal investigator’s information is entered when documenting a project. The principal investigator entered in the “Principal Investigator” table of the “INVESTIGATORS:” section of the Metadata Word form.


Personnelrole


The role as defined by EML of the person in the project. EML requires at least that the principal investigator’s information is entered when documenting a project. The principal investigator entered in the “Principal Investigator” table of the “INVESTIGATORS:” section of the Metadata Word form.
contentProvider

custodianSteward

owner

user

distributor

metadataProvider

originator

pointOfContact

principalInvestigator

processor

publisher

author

editor

Projectfunding
The name of the progra and/or agency funding this project. This information can be obtained from the section “SOURCE OF FUNDING (SPONSOR):” of the Metadata Word form.


Note: The Paradox table “EML-roles.DB” in the subdirectory “C:\htdocs-copyof\LTERCatalog\CataforXML\TOEML” contains all the roles as defined by EML.

(Go to INDEX)

Personnel Updates:

Directory: \\edaslaptop\C:\htdocs-copyof\LTERCatalog\CataforXML\TOEML

Files: mydirectory.db, TOEML-RespParty.DB, TOEML-Contacts.DB, TOEML-Creators.DB, TOEML-MeetadataProviders.DB

< 
mydirectory.db: Enter the values in the  mydirectory.db corresponding to the new data set. See Table X3 below for field values specifications.

< 
This information must be obtained directly from the person described via email or by accessing their Institution’s Web site, if known. It should be obtained preferably directly from the person since Web site are sometimes out of date by the time is accesed.

< 
There is a one-to-one correspondence between the  “CONTACTRECORDNUM” value and the person described in this database (i.e., one person does not have two or more CONTACTRECORDNUM within the whole database, nor does any CONTACTRECORDNUM belongs to more that one person. If a different table uses the CONTACTRECORDNUM it will refere to the same person.


Table X3. Fields entry specifications in the Paradox table mydirectory.db

Name of Field
Description of Value to be entered
Format (if applicable)

CONTACTRECORDNUM
A unique number that is assigned to the person in the mydirectory.db Paradox Table
natural number

GIVENNAME


First Name 
First Name + space + Middle name initial(s)

SURNAME
Last Name



SHORTFULLNAME
Full Name with First Name and Middle initial(s) and only last name spelled in full
First Name initial(s) + space + Last Name

LNOID
The LTER Network Office unique handle for the electronic mails addresses
Usually First Name Initial plus last name in full all together

E.g. emelendez

ELECTRONICMAILADDRESS


Electronic mail (E-Mail) address
<handle>@<mail server name>

ORGANIZATIONNAME
Name of University or organization


DEPARTMENT
Name of the department in the organization





ADDRESS1, ADDRESS2 
Street address and/or box number


CITY
Name of city



ADMINISTRATIVEAREA(STATE)
abbreviation of state
AA ( two characters in capital letters)

POSTALCODE
Zip Code


COUNTRY
Name or abbreviation of country



PHONE


Voice phone number
(area code)###-####

EXT
voice phone extension number, if any


FAX
Facsimil phone number
(area code)###-####

ITESSTAFF
Indicates if the person is a staff (“no-docente”) member in ITES [This field is mutually exclusive with the field ITESFACULTY]
Yes or No

ITESFACULTY
Indicates if the person is a faculty (“docente”) member in ITES. [This field is mutually exclusive with the field ITESSTAFF]
Yes or No

SCIENTIST
Indicates if the person is a scientist (researcher or investigator). [This field is mutually exclusive with the field STUDENT]
Yes or No

STUDENT
Indicates if the person is a student (research assistant). [This field is mutually exclusive with the field SCIENTIST]
Yes or No

ONLINEURL
Location of the person’s web page
http://<URL>

POSITIONNAME
position in LUQ LTER or in the person’s Institution


LTER_STATUS



< 
TOEML-RespParty.DB: Enter the information (see Table X1 below) in this table either manually or using the Paradox script “EnterRecorsinRespParty.qbe”.

< 
Manual entry of information:

< 
If entering a new record enter the next integer in the [CONTACTRECNUMBER] column (see instructions above on how to assign this number under the section to enter information in the Paradox Table mydirectory.DB). Otherwise locate the existing record: (to check for existing records locate the surname column, click on any record, press Ctrl-Z and enter last name or part of the las name with two periods - e.g., “Woolbr..”) .

< 
Under the shortname column in the TOEML-RespParty.DB template table enter the unique name of the dataset as in the TOEML-EML.DB

< 
Enter name, phone numbers, position, and LTER status into a new record’s corresponding fields or update the existing record for the values that have changed. Follow the specification of Table X1:

Table X1. Fields entry specifications in the Paradox table TOEML-RespParty.DB

Name of Field
Description of Value to be entered
Format (if applicable)

shortName
A unique number that is assigned the data set in the Metadata database (in all tables the name referes to the same data set)
LUQMetadata<record number in the Paradox Table TOEML-EML.DB>

CONTACTRECORDNUM
A unique number that is assigned to the person in the mydirectory.db Paradox Table


givenName
First Name 
First Name + space + Middle name initial(s)

surname
Last Name



electronicMailAddress
Electronic mail (E-Mail) address
<handle>@<mail server name>

organizationName
Name of University or organization


DEPARTMENT
Name of the department in the organization





ADDRESS1, ADDRESS2 
Street address and/or box number


city
Name of city



administrativeArea(state)
abbreviation of state
AA ( two characters in capital letters)

postalCode
Zip Code


country
Name or abbreviation of country



onlineURL
Location of the person’s web page
http://<URL>

phone
Voice or facsimile phone number, including extension
(area code)###-####(extension number)

phoneType
“voice” if voice phone number is given under the field “phone”; “facsimile” if FAX number is given.
voice

facsimile

role
role in regard to the data set that the record is describing
author

metadataProvider

pointOfContact

principalInvestigator

positionName
position in LUQ LTER or in the person’s Institution


< 
For each role that a person has in the data set two records must be entered in the database (one containing the voice phone number and the other containing the facsimile phone number)

OR

< 
Run the query: 1EnterRecordsinRespPartyTable-voicePhone.qbe and EnterRecordsinRespPartyTable-faxPhone.qbe  for each of the persons-roles that are listed in the Word Document version of the data set’s documentation (Metadata Word form). Look for the following sections (tables) in this document and for each of the persons listed in each table run the query. Box 1 presents the different roles according to the section the name was entered in the Metadata Word form:

Box 1. Corresponding roles of people entered in the several tables in the Metadata Word form.

Section (table) in the Word   Document
PERSON(S) COMPLETING THIS FORM

PRINCIPAL INVESTIGATORS

Other Researchers
CONTACT PERSONS

Corresponding Role

metadataProvider

author

principalInvestigator


pointOfContact

G 
Instructions to run the query 1EnterRecordsinRespPartyTable-voicePhone.qbe : 
# 
Enter/change the identifier assigned to the data set under the [shortName] field of the table template for TOEML-RespParty.DB (E.g., LUQMetadata122 - see instructions to enter information in the TOEML-RespParty.DB table above). Observe that this shortname, if absent, should be entered along with a comma and a space, making sure the paradox example element ”short” is not erased or does not change its color to black. An example element in Paradox is like a variable that holds whatever value is specified in this field or whatever value is in any record under this column.
# 
Under the field [SURNAME] of the table template for mydirectory.DB, enter the last name of the person whose role you are associating with the data set with the following format: lastname, _surname (e.g., “Klawinski, _surname”). 

< 
To verify that the name exists in the mydirectory.DB Paradox Table, either open the later and look for the last name under the field [SURNAME (Note: locate the cursor on any record of the column and hit Ctrl-Z; enter the correct name you are looking for in the “Value” window of the pop-up table) or make a query of this table where you retrieve the record containing this last name (Note: in Paradox select File>New>query>”mydirectory.DB” and enter the correct name under the [SURNAME] field of the table template for mydirectory.DB).

# 
Make sure that the value “voice” appears under the field [phoneType].

# 
Under the field [role], enter the Corresponding role (see Box 1 above)

# 
Press function key “F8" or click on the Run Query Icon on the Bar on top of your screen (represented by two wheels).

# 
Check the information inserted by examining the temporary table that Paradox pops up on your screen. This gives the opportunity to check the information and edit it if there is some mistake.

# 
Repeat this for each person-role in the Metadata Word form’s personnel tables.

< 
Instructions to run the query 2EnterRecordsinRespPartyTable-faxPhone.qbe :

# 
Enter/change the identifier assigned to the data set under the [shortName] field of the table template for TOEML-RespParty.DB.Observe that this shortname, if absent, should be entered along with a comma and a space, making sure the paradox example element ”short” is not erased or does not change its color to black.

# 
Under the field [SURNAME] of the table template for mydirectory.DB, enter the last name of the person whose role you are associating with the data set with the following format: lastname, _surname (e.g., “Klawinski, _surname”). 

< 
To verify that the name exists in the mydirectory.DB Paradox Table, either open the later and look for the last name under the field [SURNAME] or make a query of this table where you retrieve the record containing this last name.

# 
Make sure that the value “facsimile” appears under the field [phoneType].

# 
Under the field [role], enter the Corresponding role (see Box 1 above)

# 
Press function key “F8" or click on the Run Query Icon on the Bar on top of your screen (represented by two wheels).

# 
Check the information inserted by examining the temporary table that Paradox pops up on your screen. This gives the opportunity to check the information and edit it if there is some mistake.

# 
Repeat this for each person-role in the Metadata Word form’s personnel tables.

! 
TOEML-Contacts.DB: Contains the contact information for the person to be contacted for questions, comments and inquires about the data set or project. The name of the contact person and other information can be extracted directly from the Metadata Word Document section: “INVESTIGATORS:” in the “CONTACT PERSONS” table. The rest of the information can be manually or automatically obtained (by running a Paradox scripts) from the table mydirectory.DB.

< 
Manual entry of information:

< 
Table X7 below contains the information that must be entered for this table.

< 
For detail explanation of these entries refer to the section above on instructions to populate the TOEML-RespParty.DB Paradox table. 

Table X7. Structure of table TOEML-Contacts.DB, contact information for the person incharged of the data set.

shortname
A unique number that is assigned the data set in the Metadata database (in all tables the name referes to the same data set)
LUQMetadata<record number in the Paradox Table TOEML-EML.DB>

ContactgivenName
First Name 
First Name + space + Middle name initial(s)

ContactsurName
Last Name



ContelectronicMailAddress
Electronic mail (E-Mail) address
<handle>@<mail server name>

ContactorganizationName
Name of University or organization


Contactdepartment
Name of the department in the organization


ContatdeliveryPoint1
Street address and/or box number


ContatdeliveryPoint2
Street address and/or box number


Contactcity
Name of city



ContactadministrativeArea
abbreviation of state
AA ( two characters in capital letters)

ContactpostalCode
Zip Code


Contactcountry
Name or abbreviation of country



ContactonlineURL
Location of the person’s web page
http://<URL>

ContactpositionName
position in LUQ LTER or in the person’s Institution


Contactrole
role of person described in this table
pointOfContact


ContactvoicePhone
Voice phone number, including extension
(area code)###-####(extension number)

ContactfacsimilePhone






Facsimile phone number, including extension
(area code)###-####(extension number)

OR

< 
Run the query: 3GetfieldstoContactEMLvoicePhone.qbe and then 4GetfieldstoContactsEML-addfax.qbe  for the contact person that is listed in the Metadata Word form. Look for the following section in this document listing the contact person (“INVESTIGATORS:” in the “CONTACT PERSONS” table).

< 
Instructions to run the query 3GetfieldstoContactEMLvoicePhone.qbe: 

# 
Enter/change the identifier assigned to the data set under the [shortName] field of the table template for TOEML-RespParty.DB (E.g., LUQMetadata122 - see instructions to enter information in the TOEML-RespParty.DB table above). Observe that this shortname, if absent, should be entered along with a comma and a space, making sure the paradox example element ”short” is not erased or does not change its color to black.

< 
To verify that the name exists in the TOEML-RespParty.DB Paradox Table, either 

� 
open the later and look for the last name under the field [SURNAME (Note: locate the cursor on any record of the column and hit Ctrl-Z; enter the correct name you are looking for in the “Value” window of the pop-up table) or 

� 
make a query of this table where you retrieve the record containing this last name (Note: in Paradox select File>New>query>”TOEML-RespParty.DB ” and enter the correct name under the [SURNAME] field of the table template for TOEML-RespParty.DB ).

� 
Under the field [Contactrole], the string “pointOfContact” should appear.

� 
Press function key “F8" or click on the Run Query Icon on the Bar on top of your screen (represented by two wheels).

� 
Check the information inserted by examining the temporary table that Paradox pops up on your screen. This gives the opportunity to check the information and edit it if there is some mistake.

< 
Instructions to run the query 4GetfieldstoContactsEML-addfax.qbe :

# 
Enter/change the identifier assigned to the data set under the [shortName] field of the table template for TOEML-RespParty.DB.Observe that this shortname, if absent, should be entered along with a comma and a space, making sure the paradox example element ”short” is not erased or does not change its color to black.

# 
Under the field [Contactrole], the string “pointOfContact” should appear.

# 
Press function key “F8" or click on the Run Query Icon on the Bar on top of your screen (represented by two wheels).

# 
Check the information inserted by examining the temporary table that Paradox pops up on your screen. This gives the opportunity to check the information and edit it if there is some mistake.

# 
TOEML-Creators.DB: Contains the contact information for the person that was the author or creator of the data set. The name of the creator and other information can be extracted directly from the Metadata Word Document section: “INVESTIGATORS:” in the “PRINCIPAL INVESTIGATORS” table. The rest of the information can be manually or automatically obtained (by running a Paradox scripts) from the table mydirectory.DB.

< 
Manual entry of information:

< 
Table X8 below contains the information that must be entered for this table.

< 
For detail explanation of these entries refer to the section above on instructions to populate the TOEML-RespParty.DB Paradox table. 

Table X8. Structure of table TOEML-Creators.DB, contact information for the author or creator of the data set.






shortname
A unique number that is assigned the data set in the Metadata database (in all tables the name referes to the same data set)
LUQMetadata<record number in the Paradox Table TOEML-EML.DB>

ContactgivenName
First Name 
First Name + space + Middle name initial(s)

ContactsurName
Last Name



ContelectronicMailAddress
Electronic mail (E-Mail) address
<handle>@<mail server name>

ContactorganizationName
Name of University or organization


Contactdepartment
Name of the department in the organization


ContatdeliveryPoint1
Street address and/or box number


ContatdeliveryPoint2
Street address and/or box number


Contactcity
Name of city



ContactadministrativeArea
abbreviation of state
AA ( two characters in capital letters)

ContactpostalCode
Zip Code


Contactcountry
Name or abbreviation of country



ContactonlineURL
Location of the person’s web page
http://<URL>

ContactpositionName
position in LUQ LTER or in the person’s Institution


Contactrole
role of person described in this table
pointOfContact


ContactvoicePhone
Voice phone number, including extension
(area code)###-####(extension number)

ContactfacsimilePhone


Facsimile phone number, including extension
(area code)###-####(extension number)

OR

< 
Run the query: 5GetfieldstoCreatorsEMLvoicePhone.qbe and then 6GetfieldstoCreatorsEML-addfax.qbe  for the contact person that is listed in the Metadata Word form. Look for the following section in this document listing the contact person (“INVESTIGATORS:” in the “PRINCIPAL INVESTIGATORS” table).

< 
Instructions to run the query 5GetfieldstoCreatorsEMLvoicePhone.qbe: 

# 
Enter/change the identifier assigned to the data set under the [shortName] field of the table template for TOEML-RespParty.DB (E.g., LUQMetadata122 - see instructions to enter information in the TOEML-RespParty.DB table above). Observe that this shortname, if absent, should be entered along with a comma and a space, making sure the paradox example element ”short” is not erased or does not change its color to black.

< 
To verify that the name exists in the TOEML-RespParty.DB Paradox Table, either 

� 
open the later and look for the last name under the field [SURNAME (Note: locate the cursor on any record of the column and hit Ctrl-Z; enter the correct name you are looking for in the “Value” window of the pop-up table) or 

� 
make a query of this table where you retrieve the record containing this last name (Note: in Paradox select File>New>query>”TOEML-RespParty.DB ” and enter the correct name under the [SURNAME] field of the table template for TOEML-RespParty.DB ).

� 
Under the field [Contactrole] of the TOEML-Creators.DB , the string “creator” should appear. Under the field [role] of the TOEML-RespParty.DB template table, the sting “author” should appear.

� 
Press function key “F8" or click on the Run Query Icon on the Bar on top of your screen (represented by two wheels).

� 
Check the information inserted by examining the temporary table that Paradox pops up on your screen. This gives the opportunity to check the information and edit it if there is some mistake.

< 
Instructions to run the query 6GetfieldstoCreatorsEML-addfax.qbe :

# 
Enter/change the identifier assigned to the data set under the [shortName] field of the table template for TOEML-RespParty.DB.Observe that this shortname, if absent, should be entered along with a comma and a space, making sure the paradox example element ”short” is not erased or does not change its color to black.

# 
Under the field [Contactrole] of the TOEML-Creators.DB , the string “creator” should appear. Under the field [role] of the TOEML-RespParty.DB template table, the sting “author” should appear.

# 
Press function key “F8" or click on the Run Query Icon on the Bar on top of your screen (represented by two wheels).

# 
Check the information inserted by examining the temporary table that Paradox pops up on your screen. This gives the opportunity to check the information and edit it if there is some mistake.


(Go to INDEX)

Keyword Types:

Directory: \\edaslaptop\C:\htdocs-copyof\LTERCatalog\CataforXML\TOEML

Files: 
tempo-keys.db, TOEML-keywordThesaurus.DB

< 
The idea here is to populate the Paradox Table that will be exported to EML, TOEML-keywordThesaurus.DB. For that purpose, we prepare a temporary Paradox file called “tempo-keys.db” so we can run the query 9AddKeysFromtempo-keys_db.qbe. The table tempo-keys.db is created as a new table in Paradox for every data set we are creating keywords in EML for.

< 
From the following sections in the completed Metadata Word form listed in Box 2 below, all the sets of keywords should be extracted:




Box 2. Sections of the Metadata Word form to extract sets of keywords from

Section in Completed Metadata Form
LTER CORE AREAS: 
LEF LTER 1 RESEARCH  TOPIC: 
INVESTIGATOR'S ASSIGNED KEYWORDS:
LEF LTER OFFICIAL KEYWORDS
Name of Keyword Set
LEF LTER Data Sets Keyword List

LUQ LTER 1 Research Area

Investigator Assigned

LEF LTER Data Sets Keyword List

< 
To generate a new tempo-keys.db that will contain all the data set’s keywords the existing tempo-keys.db table has to be empty and populated with all the keyword sets in the completed Metadata Word form of the new data set (see Box 2 above). 

G 
Empty the table with the sequence of menu items: Tools > Utilities >Empty > SELECT THE tempo-keys.db FROM THE WORKING DIRECTORY IN THE BROWSE WINDOW PROMPTED ON YOUR SCREEN 




> CLICK ON THE [Yes] BUTTON WHEN THE WARNING! BOX POPS




    UP

G 
To transfer keywords from the sections "LTER CORE AREAS:" and "LEF LTER 1 RESEARCH  TOPIC:" of the Metadata Word form:

G 
Feed the sets of keywords into the tempo-keys.db opening this table from QPRO and copying (Edit > Copy) the keywords directly from the completed Metadata Word Form tables (NOTE: to paste from the Word form to the QPRO file use the sequence of menu items: Edit > Paste Special > text (or Unformatted text under the “KEYWORD” column in the tempo-keys.db file).

G 
Add the short name of the metadata data set under the column “SHORTNAME” column in the tempo-keys.db file. (See Table X2 above for a description of this field).

G 
Add the name of keyword set according to Box 2 above to all corresponding records.

# 
To import keywords from the sections "INVESTIGATOR'S ASSIGNED KEYWORDS:" and "LEF LTER OFFICIAL KEYWORDS” of the Metadata Word form:

G 
Copy the comma-delimited list from the section (Edit > Copy from the Word document)

G 
Paste the copied string in a text editor (Wordpad, Notepad, Word, Wordperfect) and save it as an ASCII comma-delimited file (e.g., tempo-keys) and from Excel or QPRO, import that file. (Example, in QPRO : File > Open > SET “File type” window to “ASCII text (*.txt)” > SELECT THE JUST SAVED FILE file (e.g., tempo-keys). Make sure that that the cell  delimiters in the settings (click the  “Settings...” button) are set to comma only, and click the “OK” button.

G 
Transpose the row of just imported keywords. In QPRO this is achieved by selecting the list (highlight all the keywords) and doing the sequence of keystrokes: Tools > Numeric Tools > Transpose (or, if available, click on the Transpose icon on the toolbar) and then selecting a cell where the column of keywords will begin.

G 
Copy and paste the new column of keywords into the ”KEYWORD“ column of the “tempo-keys.db” file.

G 
Add the short name of the metadata data set under the column “SHORTNAME” column in the tempo-keys.db file. (See Table X2 above for a description of this field).

G 
Add the Name of keyword set according to Box 2 above  to all corresponding records.

G 
Make sure to eliminate all spaces before keywords; they add innecesary character to the word making it difficult to sort any list they are in. Also make sure to save your work as a Paradox table in tempo-keys.DB, and to close this table from QPRO, otherwise, Paradox will not be able to work with it! 

# 
From Paradox, run the query 9AddKeysFromtempo-keys_db.qbe to add the sets of keywords in tempo-keys.DB to the Paradox table
“TOEML-keywordThesaurus.DB”.

(Go to INDEX)

� 
Export all metadata tables to XML from Paradox to ACCESS
Data Base conversion to XML:

Directory: \\edaslaptop\C:\htdocs-copyof\LTERCatalog\CataforXML\TOEML

Files: TOEML-EML.DB, LUQ-descriptions.DB, TOEML-projects.DB, TOEML-Contacts.DB, TOEML-Creators.DB, TOEML-MetadataProviders.DB, TOEML-keywordThesaurus, TOEML-luq-Methods-Abs-ProjectDesc.mdb, TOEML-EML.xml, LUQ-descriptions.xml, TOEML-projects.xml, TOEML-Contacts.xml, TOEML-Creators.xml, TOEML-MetadataProviders.xmlTOEML-keywordThesaurus

� 
“TOEML-luq-Methods-Abs-ProjectDesc.mdb:  From ACCESS, open this database file to export all the metadata data files to XML.

# 
Eliminate all original files listed in Box 3 below from the database in ACCESS.

# 
Import a Paradox table listed in Box 3 below with the following sequence of keystrokes: File > Get external data > Import > SELECT “Paradox (*.db)” in the “Files of type” scrolldown window > SELECT THE PARADOX TABLE FROM THE “Name” windows > Import. A “Successfully imported ‘<table name>” pop-up window will appear on your screen.( NOTE: If the tables already existed in ACCESS the new ACCESS table with the new imported data will be name “<table name>1").

# 
The Import window will remain on your screen so you can repeat the following sequence of keystroke for each Paradox table to be imported:

SELECT THE PARADOX TABLE FROM THE “Name” windows > Import. 

Box 3. Paradox tables that contain the metadata for the conversion to XML

Paradox Table Name
ACCESS Table name

TOEML-EML

LUQ-descriptions.DB

TOEML-projects.DB

TOEML-Contacts.DB

TOEML-Creators.DB

TOEML-MetadataProviders.DB

TOEML-keywordThesaurus.DB
TOEML-EML

LUQ-descriptions

TOEML-projects

TOEML-Contacts

TOEML-Creators

TOEML-MetadataProviders

TOEML-keywordThesaurus

# 
*.XML: From ACCESS export all tables in Box 3 to XML

# 
Select the file to export and follow the sequence of Menu selections: File > Export > SELECT THE OPTION  “XML (*.xml)” FROM THE SCROLLDOWN WINDOW “Save as Type:” > SELECT THE SUBDIRECTORY (FOLDER) ON THE WINDOW “Save in:” > CLICK ON THE “Export” button

# 
Make sure the following options from the pop-up box “Select what information will be exported” are selected:

G 
Data (XML)

G 
Schema of the data (XSD)

If the files already exist click the “yes” button when asked if you want to substitute the existing file.

< 
*.EML: Generate the EML packages by using the script programed by Inigo of the LNO.

EML Packages: 

Directories: 

\\edaslaptop\C:\NewWeb-copyof\luq\EcologicalMetadataLanguage\LUQEML-XML\ \\edaslaptop\C:\NewWeb-copyof\luq\EcologicalMetadataLanguage\LUQEML-XML\LUQEMLFiles

www.ites.upr.edu/var/apache/htdocs/luq/EcologicalMetadataLanguage/LUQEMLFiles

Files: *.XML, *.EML

# 
From the DOS command prompt (C:\NewWeb-copyof\luq\EcologicalMetadataLanguage\LUQEML-XML) run the script “luq.dat” to generate the EML packages

G 
Got to start > run > OK

G 
Type “gotoluq” to run the batch file “gotoluq.bat” that will move the cursor to the subdirectory: C:\NewWeb-copyof\luq\EcologicalMetadataLanguage\LUQEML-XML\

G 
Run the batch file luq.dat by typing “luq” on the command prompt


# 
Copy the EML Packages to the Desktop for backups and publish them on the Web server

G 
From the Internet Explorer, go to the subdirectory: C:\NewWeb-copyof\luq\EcologicalMetadataLanguage\LUQEML-XML\LUQEmlFiles

G 
select all files (Ctrl-A) and copy the files (NOTE: from the “Files and Folders Tasks” submenu “Copy the selected items”) to:

$ 
\\Dmxp1\newweb\luq\EcologicalMetadataLanguage\LUQEMLFiles, and to

C:\NewWeb-copyof\luq\EcologicalMetadataLanguage\LUQEMLFiles
G 
From DreamWeaver (Start > DreamWeaver) transfer the new EML files to the server subdirectory www.ites.upr.edu/var/apache/htdocs/luq/EcologicalMetadataLanguage/LUQEMLFiles

$ 
To select the folder to be transfered to the server, from Dreamwaver, highlight the directory: \luq\EcologicalMetadataLanguage\LUQEML-XML\LUQEmlFiles

$ 
Use sequence of Menu items: Site > Put, to transfer all the files.

� 
Harvest the EML packages from Metacat

Directory: http://knb.lternet.edu:8088/knb/style/skins/knb/harvesterRegistrationLogin.html

INDEX Phase 2 EML conversion of LUQ Metadata (by sections-type of information saved in Paradox table):



Data Table entries: 

Directory: \\edaslaptop\C:\htdocs-copyof\LTERCatalog\CataforXML\TOEML

Files: TOEML-dataTable.DB
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